Diskussionsforum
Menü

Ursache und Lösung


26.03.2012 21:11 - Gestartet von CBS
Mit Hilfe von IP Phone Forum Usern herausgefunden:

Ursache:

Grund ist ein falscher TZ-Eintrag in der Fritzbox. Wenn man sich per telnet anmeldet wird mit 'set' TZ='CET-1CEST-2,M3.5.0/02:00:00,M10.5.0/03:00:00' angezeigt.

Gibt man 'date' ein, wird "Sun Mar 25 12:27:30 CET 2012" ausgegeben, d.h. die FB hat noch nicht gemerkt, dass sie Sommer- statt Winterzeit anzeigen muss (die interne Zeit ist immer UTC, das Problem ist nur die Anzeige).

Ursache ist, dass der 25.3. in Europa nicht in der 5. sondern in der 4. Woche des Monats liegt.

Folgende Lösungen:
1. eine Woche warten, dann müsste auch die FB gemerkt haben, dass Sommerzeit herrscht.

2. den TZ-String ändern (alle Angaben ohne Gewähr, bei mir hat's so funktioniert):

- telnet aktivieren (falls nicht aktiv): per Telefon #96*7*
- per 'telnet fritz.box' an der Fritzbox anmelden
- per 'nvi /var/flash/ar7.cfg' die Konfigurationsdatei zum Bearbeiten öffnen (es handelt sich um einen vi, Erklärungen zur Bedienung muss man an anderer Stelle suchen)
- den Abschnitt 'timezone_manual' folgendermaßen ändern:
timezone_manual {
enabled = yes;
offset = 0;
dst_enabled = yes;
TZ_string = "CET-1CEST-2,M3.4.0/02:00:00,M10.5.0/03:00:00";
name = "Europe/Berlin";
}
(4. Woche im März statt 5.)
- die FB neu starten
- ggf. telnet mit #96*8* per Telefon wieder deaktivieren


Allerdings ist dies nicht der korrekte Weg, die Sommerzeit zu detektieren . Hierzu muss man den letzten Tag des Monats erkennen und durch Rückrechnen den letzten Sonntag bestimmen. Das Schaltjahr, laut AVM Ursache, dürfte keine Rolle spielen.


Kurzfristige Abhilfe bis nächste Woche:

1. Automatische Zeitsynchro deaktivieren.

2. Korrekte Zeit und Datum über den Telefonhörer wie folgt eingeben:

# 8 3 * hh mm TT MM JJJJ *

wobei:
hh: Stunde
mm: Minute
TT: Tag
MM: Monat
JJJJ: Jahr

Zum speichern noch # 9 1 * * wählen.


Danke an alle Mit-Untersucher im Forum dort.
Menü
[1] bholmer antwortet auf CBS
27.03.2012 13:56
Bleibt die Zeit nach manueller Eingabe denn bestehen oder wird dann von der Box wieder rübersynchronisiert?

Übrigens wird die falsche Zeit auch über den S0-Bus an meine schnurlose ISDN-Anlage (Siemens SX255) übermittelt)

Bert

Menü
[2] fb antwortet auf CBS
28.03.2012 08:49
Benutzer CBS schrieb:
- den Abschnitt 'timezone_manual' folgendermaßen ändern: timezone_manual {
enabled = yes;
offset = 0;
dst_enabled = yes;
TZ_string = "CET-1CEST-2,M3.4.0/02:00:00,M10.5.0/03:00:00"; name = "Europe/Berlin";

Von dieser "Lösung" kann ich nur abraten, denn sie wird in anderen Jahren zu Fehlern führen, nämlich immer dann, wenn ein März fünf Sonntage hat. Dann würde die Uhr schon am vierten Sonntag, also eine Woche zu früh, umgestellt. Und diese Konstellation kommt erheblich häufiger vor als die Konstellation, die zum aktuellen Fehler führt.
Menü
[2.1] CBS antwortet auf fb
28.03.2012 13:19
Benutzer fb schrieb:
Benutzer CBS schrieb:
- den Abschnitt 'timezone_manual' folgendermaßen ändern: timezone_manual {
enabled = yes;
offset = 0;
dst_enabled = yes;
TZ_string = "CET-1CEST-2,M3.4.0/02:00:00,M10.5.0/03:00:00"; name = "Europe/Berlin";

Von dieser "Lösung" kann ich nur abraten, denn sie wird in anderen Jahren zu Fehlern führen, nämlich immer dann, wenn ein März fünf Sonntage hat. Dann würde die Uhr schon am vierten Sonntag, also eine Woche zu früh, umgestellt. Und diese Konstellation kommt erheblich häufiger vor als die Konstellation, die zum aktuellen Fehler führt.

Der Fehler ist in Busybox eh schon korrigiert, nur noch nicht übernommen worden. Wer diesen String ändert wird in den folgenden Jahren falschen Anzeigen bekommen, diese Möglichkeit gilt nur für diese Woche.

_Deshalb_ die andere Lösung bevorzugen. Timeserver deaktivieren, manuell Uhrzeit über Telefon eingeben. Das reicht bis kommende Woche.

Die Box synchronisiert übrigens trotz fehlendem Häckchen bei der autom. Einstellung, von daher den Zeitserver einfach falsch eintragen. Ich habe für diese Woche einfach ein x angehängt, die Uhrzeit ist seither in Ordnung. Am Sonntag stelle ich die Automatik wieder ein. Problem einfach gelöst.